MikroTik RouterOS

Z Wikipedie, otevřené encyklopedie
Skočit na navigaci Skočit na vyhledávání
Embedded systém v podobě RouterBOARDu 112 s U.FL-RSMA pigtailem, R52 miniPCI Wi-Fi kartou a MikroTik RouterOS

MikroTik RouterOS je routerový operační systém založený na Linuxu, vhodný zejména pro bezdrátové spoje a jako bezpečný HW firewall popřípadě router se snadnou GUI konfigurací. Komunikace s tímto OS se v současnosti provádí zejména přes GUI Winbox, SSH, Telnet, sériovou konzoli, Mac-Telnet (specifický protokol komunikující po 2. síťové vrstvě na správu OS bez zavedení IP adres). Dnes je tento OS zejména uplatňován u kvalitních bezdrátových spojů 802.11a, 802.11b/g a 802.11n.

Winbox[editovat | editovat zdroj]

Jedná se o propracované GUI, jehož prostřednictvím lze spravovat většinu prvků v systému MikroTik RouterOS.

Forma distribuce[editovat | editovat zdroj]

Tento routerový operační systém je koncipován pro platformy: i386, mips, powerpc a je distribuován v podobě instalačních balíčků NPK pro embedded řešení, v podobě předinstalovaného systému na RouterBOARDu či v podobě klasického ISO souboru jako obrazu CD k vypálení.

Historie[editovat | editovat zdroj]

Vývoj MikroTik RouterOS sahá do roku 1995 kdy společnost MikroTik začala svou činnost vývojem a prodejem bezdrátových systémů zejména pro ISP. Původně byl tento OS vyvíjen v Lotyšsku pro dřívější Sovětský svaz. Následné zkušenosti s PC přivedly vývojáře k vybudování routovacího software MikroTik v2 PC, který přinesl výraznou stabilitu, ovladatelnost a flexibilitu pro všechny typy komunikačních periférií a kompatibilitu routovacích systémů založených na standardu PC.

Praktické použití[editovat | editovat zdroj]

Příklad nastavení[editovat | editovat zdroj]

Následující příklad demonstruje základní nastavení routeru - překlad adres NAT z vnitřní sítě 192.168.1.0/24 na fiktivní veřejnou adresu 1.2.3.5.

/ip address add address=192.168.1.1/24 interface=ether1
/ip address add address=1.2.3.5/25 interface=ether2
/ip route add dst-address=0.0.0.0/0 gateway=1.2.3.6
/ip firewall nat add chain=src-nat action=masquerade out-interface=ether2

Jak se naučit s Router OS[editovat | editovat zdroj]

Pro práci s tímto systémem vám vždy nemusí stačit obecné znalosti o síti a jejích prvcích proto je vhodné čerpat informace z webu výrobce, kde je k dispozici kvalitní a rozsáhlá dokumentace.

Externí odkazy[editovat | editovat zdroj]